LogicMonitor is currently investigating impacts to our LM Cloud Component(s) for MS Azure
Incident Report for LogicMonitor
Resolved
This incident has been resolved.
Posted Aug 02, 2023 - 11:48 CDT
Monitoring
June 23rd - Began deploying Hotfixes of LM Cloud. After deployment, customers will begin to observe the duplicate “US-C1” prefixed devices beginning to be marked as “device dead”. Devices will be removed automatically from portals according to each customer’s configured setting, if the “Automatically delete Azure resources if they are no longer available in the cloud portal.” setting is enabled. Some customers may still continue to notice “US-C1" prefixed dynamic groups within some Azure services. These dynamic groups do not consume any API calls or incur any charge at the LM level and will be cleaned up in the 190 release.

July 24-31st - We will deploy v190 of LogicMonitor to ensure full remediation (removal of dead devices) as well as any "US-C1" prefixed dynamic groups. This release will remove any “US-C1” prefixed devices that were not already removed (i.e., if the customer did not elect to automatically remove dead devices in their portal) as well as any “US-C1" prefixed dynamic groups. This release will incur ~5 minutes of portal downtime as per our standard Deployment Schedule - https://www.logicmonitor.com/support/about-logicmonitor/overview/logicmonitor-maintenance-window .

We will continue to deploy non-service-impacting Hotfixes when possible to accelerate the full remediation. There will be no further updates on our Status Page for this issue.

You may contact your Customer Success Manager for any follow-up questions.
Posted Jun 26, 2023 - 18:46 CDT
Update
LogicMonitor is working on a comprehensive plan and timeline to fully remediate this issue. We expect to share this on Monday June 26th by 5pm PT.
Posted Jun 22, 2023 - 14:23 CDT
Update
LogicMonitor is still continuing to investigate the best approach for removing the incorrectly added duplicate devices. We have identified all customers that have been affected by this disruption and are working to deploy a hotfix to the LM Cloud component that caused the duplicate resources. The next update should be around 12pm PT on Thursday June 22nd. Please note that this update time is an estimate and may change depending on the efforts of our Engineering team
Posted Jun 21, 2023 - 16:30 CDT
Update
We have rolled back the component responsible for adding duplicate Azure devices. We are continuing to investigate the best approach for removing the incorrectly added duplicate devices. The next update will be around 10am PT on Wednesday June 21st.
Posted Jun 20, 2023 - 19:37 CDT
Identified
LogicMonitor has identified an issue with our LM Cloud application that may be creating duplicate Azure devices for some customer's accounts. We are currently working towards remediating the issue with our Engineering backend team. We will provide further updates in approximately 2 hours, or if more information is uncovered.
Posted Jun 20, 2023 - 17:32 CDT
Investigating
LogicMonitor is currently investigating technical abnormalities, which may be impacting customer accounts. We will update once we have further information on the full scope of impact.
Posted Jun 20, 2023 - 17:27 CDT
This incident affected: EMEA Region (LM Cloud), AMER - EAST Region (LM Cloud), AMER - WEST Region (LM Cloud), and APAC - Sydney (LM Cloud).