LogicMonitor is currently investigating potential impacts to our Account Access Component(s).

Incident Report for LogicMonitor

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 20:26 CST

Monitoring

We have implemented a fix and are observing positive results. System performance is continuing to stabilize. We will continue monitoring closely and will post another update once the issue is fully resolved and service is confirmed to be operating normally.
Posted Nov 14, 2025 - 19:31 CST

Identified

We have identified the root cause of the ongoing service disruption and have begun implementing remediation steps. Initial indicators show system performance is improving.

We continue to monitor closely and will provide further updates as more information becomes available.
Posted Nov 14, 2025 - 19:21 CST

Investigating

LogicMonitor is currently investigating technical abnormalities, which may be impacting customer accounts. We will update once we have further information on the full scope of impact.
Posted Nov 14, 2025 - 18:59 CST
This incident affected: GovCloud (Account Access).