The issue impacting data visualization has been fully resolved. Services have returned to normal, and all data has been restored. We will continue to monitor to ensure ongoing stability.
Posted Apr 21, 2026 - 17:04 CDT
Update
Services continue to normalize following the earlier issue, and data visualization is steadily returning to normal. The platform is showing positive recovery progress, though full restoration will take a little more time. We will continue monitoring until recovery is complete.
Posted Apr 21, 2026 - 15:01 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 12:24 CDT
Investigating
LogicMonitor is currently investigating an issue that began around 9:40 PM EDT on April 20, 2026, impacting data visualization for some customers. Our team has identified the cause and implemented a fix. Data is now being restored, and we continue to monitor progress to ensure full recovery.
Posted Apr 21, 2026 - 11:30 CDT
This incident affected: AMER - EAST Region (Graphing).