LogicMonitor is currently investigating potential impacts to our Account Access, Alert Delivery, Time Series Data Ingestion and Persistence Component(s).
All services have been fully restored and the incident has been resolved. We are continuing to monitor for sustained stability.
Posted Oct 09, 2025 - 13:19 CDT
Monitoring
A fix has been implemented and we’re monitoring service operations to ensure full recovery.
Posted Oct 09, 2025 - 12:29 CDT
Update
Our teams continue to implement corrective actions and will keep customers updated as progress is made.
Posted Oct 09, 2025 - 11:56 CDT
Identified
Resolution efforts are in progress and will share more information soon.
Posted Oct 09, 2025 - 11:10 CDT
Update
We are continuing to investigate the issue, our team is actively working to identify the root cause and will provide additional updates as soon as more information is available.
Posted Oct 09, 2025 - 10:34 CDT
Investigating
LogicMonitor is currently investigating technical abnormalities, which may be impacting customer accounts. We will update once we have further information on the full scope of impact.