LogicMonitor Extended Maintenance APAC - Singapore

Scheduled for Jul 9, 10:00 - 16:00 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 08, 2026 - 18:21 CDT

Scheduled

LogicMonitor will be performing extended platform maintenance during our weekly Routine Maintenance window on July 9th, 2026 between 8am - 2pm PT or 11pm - 5am SGT.

During this maintenance window LogicMonitor services that rely on the underlying platform may experience brief interruptions and will resume normal operations immediately afterwards.

If you have any questions or need help, contact Support via the in-portal chat or submit a ticket here:
https://support.logicmonitor.com
Posted Jul 08, 2026 - 18:20 CDT
This scheduled maintenance affects: APAC - Singapore (Other).