Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 11, 2025 - 20:00 CST
Update
LogicMonitor will be performing extended platform maintenance during our weekly Routine Maintenance window on Dec 11th, 2025 between 6pm - 12am PT.
During this maintenance window LogicMonitor portal services will experience brief interruptions and will resume normal operations immediately afterwards.
If you have any questions or need help, contact Support via the in-portal chat or submit a ticket here: https://support.logicmonitor.com
Posted Dec 10, 2025 - 12:01 CST
Scheduled
LogicMonitor will be performing extended platform maintenance during our weekly Routine Maintenance window on Dec 11th, 2025 between 6pm - 12am PT.
During this maintenance window LogicMonitor portal services will experience brief interruptions and will resume normal operations immediately afterwards.
If you have any questions or need help, contact Support via the in-portal chat or submit a ticket here: https://support.logicmonitor.com
Posted Dec 09, 2025 - 17:38 CST
This scheduled maintenance affected: GovCloud (Time Series Data Ingestion and Persistence), EMEA - West (Time Series Data Ingestion and Persistence), APAC - Sydney (Time Series Data Ingestion and Persistence), and APAC - Singapore (Time Series Data Ingestion and Persistence).