LogicMonitor is currently investigating potential impacts to our Technical Support Component(s).
Incident Report for LogicMonitor
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 02:31 CDT
Investigating
LogicMonitor is currently investigating technical abnormalities, which may be impacting customer accounts. We will update once we have further information on the full scope of impact.
Posted Jun 21, 2022 - 02:22 CDT
This incident affected: External Website Check Locations.