Email delivery problems for some customers
Incident Report for LogicMonitor
Resolved
At this time the LogicMonitor operations team has received confirmation from SpamHaus and have verified that all of our IPs have been removed from the blocklist. This issue is declared to be resolved.
Posted Sep 14, 2022 - 12:19 CDT
Update
LogicMonitor continues to investigate issues with email delivery for some customers. At this time customers using SpamHaus email filtering may continue to experience intermittent issues.

We are working with SpamHaus for a permanent whitelisting solution, however, we have identified the cause of our continual blacklisting as use of nonexistent/invalid email addresses in escalation chains or report recipients.

Affected customers can take the following steps to mitigate impact to their services:

- Whitelist logicmonitor.com domain

OR

- Whitelist the following SMTP gateway IPs:
69.25.43.123 69.25.43.124
212.118.245.8 212.118.245.9
74.201.65.5 74.201.65.6
Posted Sep 13, 2022 - 10:06 CDT
Identified
Our Technical Operations team is currently investigating reports of issues with email delivery. The problem has been isolated to a third-party email client and a temporary fix is in place while we work to deliver a permanent solution.
All LogicMonitor services are unaffected.
Posted Sep 12, 2022 - 11:40 CDT