LogicMonitor is currently investigating potential impacts to our (Alert Delivery) Component(s).
Incident Report for LogicMonitor
Resolved
This incident has been resolved.
Posted 28 days ago. Jul 21, 2019 - 21:33 CDT
Investigating
LogicMonitor is currently investigating technical abnormalities, which may be impacting customer accounts. We will update once we have further information on the full scope of impact.
Posted 28 days ago. Jul 21, 2019 - 17:00 CDT
This incident affected: EMEA Region.