Support Chat Unavailable for all customers.
Incident Report for LogicMonitor
Resolved
Support Chat is currently experiencing technical difficulties.
If you have an urgent request, such as being unable to access your account, please submit an Urgent priority ticket at the link below or via the "Submit a Support Ticket" option under the Contact Support section in your account. Thank you.

- LogicMonitor Support Management

support.logicmonitor.com/hc/en-us/requests/new

Support chat service has been restored. Please contact us on chat with any further questions or comments in this matter.

Resolved:
March 27, 2019 11:31AM PDT
March 27, 2019 6:31PM UTC
Posted 5 months ago. Mar 27, 2019 - 09:16 CDT